Page 1 of 2

PopTray U and K9 on Win 8.1

Posted: Thu Feb 13, 2014 8:17 pm
by kandoo
I have used PopTray 3.2 and K9 on Win XP for years. I recently installed PopTray U and K9 on a Windows 8.1 VM running on a MacBook Pro. After moving the configuration and other files for PopTray 3,2 (as suggested in another posting in this forum) to the appropriate locations for PopTray U on the Windows VM, and configuraing K9 exactly as it was configured on the Win XP machine, PopTray U is working fine, but the emails are not being filtered through K9. I have given both programs internet access via the firewall, both are being loaded via startup in the VM, and the K9 log seems to indicate that its processing the emails, but they never appear in the Recent Emails tab. The only difference in this setup, other than the OS, is that the Thunderbird email client is being launched from PopTray U instead of Outlook Express. I have double-checked the configuration and Advanced tabs of K9 and the settings are identical to before. This is easy to check as I still have both programs installed on the XP machine. They just aren't actively checking for email on the XP machine.

Can anyone suggest what may be the issue? I have

Posted: Fri Feb 14, 2014 12:00 am
by Rdsok
The usual place a mistake would be made are the ports being used... K9 is the software that directly access's the mail server ( if properly configured ) and then Poptray access's the ports as you are told to setup in the configuration settings and then access's the email direct from K9 and not your email server.

Instead of just repeating what's already been mentioned... I'll link you to the K9 website which has the proper setup info http://keir.net/k9_begin.html ... and an alternate ( but the same info ) by KY Dave viewtopic.php?t=2883

Posted: Fri Feb 14, 2014 12:39 am
by kandoo
Thanks for replying so quickly. As I mentioned, I've been using the two programs together for many years. My original configuration was based on the link to the PopTray forum you provide in your post. My settings for K9 and the accounts in PopTray U are using port 9999 and the server number as in the instructions and they have access to all ports via the firewall, so I'm completely perplexed as to what might be the problem. Like I said, when I review the K9 logs it appears to be connecting to the POP servers without a problem and logging into the mail accounts and it indicates that emails are being entered into the Spam IP cache and Good IP cache, but they never appear in the Recent Emails tab where I usually review them before clicking the Organize button or in the storage areas. The storage area lists all of the Good and Spam messages from my old configuration so I know that the program is able to see the configuration files on the new machine. Any help or other ideas you might have will be appreciated.

Posted: Fri Feb 14, 2014 1:53 am
by Rdsok
Since this isn't a K9 forum and I don't use it... there is little else I can suggest.

From the sound of it that is where the problem is since Poptray is connecting with it and you can see emails... if it were Poptray ... you wouldn't get a connection using that port number you would get errors... so it isn't a Poptray issue at least.

All I could suggest is to start with a clean install on both... reset them back up and see if the issue is fixed or acts the same.

Posted: Fri Feb 14, 2014 5:52 pm
by kandoo
You're right. PopTray U is able to connect using the 9999 port and I noticed today that the [Spam] indicator is being placed in the subject line of Spam emails displaying in PopTray U, as it's configured to do in K9, so PopTray U is obviously using the K9 proxy. I just need to figure out why the messages are not appearing in the Recent Emails tab of K9 and therefore not giving me the option to review and organize them before K9 automatically does so after the configured period. Thanks for your help. I'll continue to investigate.

Posted: Wed Feb 26, 2014 1:11 pm
by KY Dave
kandoo wrote:You're right. PopTray U is able to connect using the 9999 port and I noticed today that the [Spam] indicator is being placed in the subject line of Spam emails displaying in PopTray U, as it's configured to do in K9, so PopTray U is obviously using the K9 proxy. I just need to figure out why the messages are not appearing in the Recent Emails tab of K9 and therefore not giving me the option to review and organize them before K9 automatically does so after the configured period. Thanks for your help. I'll continue to investigate.
You might need to download the entire email using the settings in PopTrayU, ADVANCED OPTIONS, RETRIEVE BODY WHILE CHECKING, for it to show up in K9's RECENT EMAIL section.

Otherwise, K9 is just using it's BLACKLIST feature to label SPAM.

It's been a long time since I used K9, hope this solves your issue.

Posted: Wed Feb 26, 2014 3:48 pm
by kandoo
Thanks again for trying to help. I've used K9 for a while and I'm not familiar with that feature. I've looked all over the Advanced and Configuration tabs and there is no RETRIEVE BODY WHILE CHECKING. Where did you see this feature? I've written to both the K9 developer and the PopTray U discussion board and they haven't yet been able to help.

Posted: Thu Feb 27, 2014 6:58 pm
by KY Dave
KY Dave wrote: You might need to download the entire email using the settings in PopTrayU, ADVANCED OPTIONS, RETRIEVE BODY WHILE CHECKING, for it to show up in K9's RECENT EMAIL section.
It's in PopTray on the ADVANCED OPTIONS tab, then check the box for RETRIEVE BODY WHILE CHECKING.

Posted: Thu Feb 27, 2014 9:07 pm
by kandoo
I'm sorry, that option in PopTray U is checked, as it was with PopTray 3.2. If I check the options in the K9 Advanced tab to translate TOP commands into RETR commands the messages appear in the Recent Email tab of K9 but do NOT get passed through to PopTray U and therefore cannot be loaded into my mail client (Thunderbird). However, if I do NOT check the options in K9 to translate the commands, they get passed through to PopTray U and can therefore be downloaded into my mail client, but never appear in K9, and therefore cannot be reviewed for spam and organized. It's extremely frustrating. I don't understand why the commands would change from 3.2 to the new U version of PopTray.

Posted: Fri Feb 28, 2014 1:10 pm
by KY Dave
My best guess is that your antivirus program/setting is different and once the message is considered as being read, it no longer relays it to PopTrayU.

I would suggest turning off the antivirus or at least the email scanning feature for a few minutes and then checking to see if PopTray and K9 works properly. I would not leave the antivirus off after the test.

Posted: Fri Feb 28, 2014 5:25 pm
by kandoo
Thanks. I had tried that with no luck. However, I'm not sure why, but after updates this morning to both Windows 8.1 and to OSX, K9 and PopTray U seem to be working correctly this morning. At least for one of my accounts, the eight messages were in both PopTray inbox and the K9 recent Mail tab. Thanks a lot for your help. I will let you know if I ever discover exactly what was the source of the problem.

Posted: Thu Mar 06, 2014 7:41 pm
by kandoo
KY Dave - My emails are now appearing in both the K9 Recent Email folder and in the PopTray U inboxes. Thanks for your help. However, I now have noticed another issue. I have always used the "Mark as Spam" and "Delete Spam" rules you provided in your 2005 "Stickey" post on "How To Setup PopTray And K9 To Remove Spam" and it always worked perfectly with PopTray 3.2, but with PopTray U, while K9 is placing the [Spam][XX.X%] markers at the beginning of the subject line (as configured in K9) and I have checked all of the proper check boxes beneath the rules in PopTray U, PopTray U isn't marking the email as spam or deleting the spam. I have to do so manually. Any idea what might be the problem?

Posted: Tue Apr 08, 2014 9:11 pm
by KY Dave
Make sure you have the correct COMPARE setting. I think it should be CONTAINS. If you are using EQUALS, it won't work because every subject has other text included. If you use WILDCARD there must be an ASTERISK before and after the TEXT you are matching.

Posted: Tue Apr 08, 2014 10:24 pm
by kandoo
Hi KY Dave - I'm using the WILDCARD Compare with ASTERISKS. The rules were imported from the PopTray 3.2 settings and are just as you posted in the forum so they haven't changed. Do you think it might work better to delete the asterisks and use the CONTAINS Compare setting? Or, do you recommend I convert from K9 to PopFile?

Posted: Tue Apr 08, 2014 11:14 pm
by KY Dave
Make sure the RULE is ENABLED.
Make sure the RULE is set for ALL ACCOUNTS.

ie: POPFILE VS K9
I switched to POPFILE because I could not use SSL going through K9. How do you avoid that problem?

Posted: Wed Apr 09, 2014 12:50 am
by kandoo
Thanks. The rules are ENABLED and set for ALL ACCOUNTS. If you can believe it, I haven't been using SSL. Crazy huh? That's another reason I was considering a move to PopFile. However, it makes me nervous that there isn't a UI.

Posted: Wed Apr 09, 2014 1:26 am
by KY Dave
There is a UI that opens in your default browser.

Below is a link to the Help File documentation for the UI.
http://getpopfile.org/docs/ui

Don't get me wrong, PopFile doesn't have as much graphics as K9, but it is sufficient to make the settings that are needed. Something that is missing is the percentage ranking that K9 has. But, PopFile will sort email as well as K9 did, it uses MAGNETS for subject, to, from, CC and user defined. The magnets are like rules in PopTray only easier.

Below are my results...

Classification Accuracy
Messages classified: 13,704
Classification errors: 7
Accuracy: 99.94%
(Last Reset: Thu Nov 14 07:29:07 2013 )

Bucket Classification Count False Positives False Negatives
bill_pay 585 (4.26%) 0 0
delete 519 (3.78%) 0 2
personal 907 (6.61%) 0 0
read_this 3,206 (23.39%) 6 1
spam_mail 8,375 (61.11%) 1 4
unclassified 112 (0.81%) 0

Sorry, the forum won't put them inline like they are on the UI.

Posted: Fri Apr 11, 2014 4:28 pm
by kandoo
Thanks for the info. I may give it a try when I can find the time. While K9 is doing a great job of identifying and marking the SPAM, it's becoming more and more of a headache to have to either create new rules in PopTrayU for every SPAM message and then click "Check" to delete, or to just delete the messages, when the Wildcard rules should be working. Thanks for all of your help. Unless someone at PopTrayU responds to my complaints, which doesn't seem likely, I will probably move to PopFile.

PopTray U and K9 on Win 8.1

Posted: Thu May 15, 2014 8:18 pm
by homaquebec
I got a new computer running with Windows 8.1.

I first installed PopTray and K9 and Set up them the way I used to do with Windows 7. After having created a rule, in PopTray, to mark as Spam..., it did not work.

So, I started at new. I discovered the new version of K9. I downloaded PopTray U - what a surprise to see that the languages have been kept - and set up the two programs.

Using just an account - the one from my Internet Service Provider - everything works fine. I do not delete spam now; it will come later.

I'll see later if I add my webmail accounts using a plugin.

Thanks to Jessica Brown, to KY Dave and to Rdsok.

Re:

Posted: Mon Jun 12, 2017 10:38 am
by acanais63
kandoo wrote:
Fri Feb 14, 2014 12:39 am
Thanks for replying so quickly. As I mentioned, I've been using the two programs together for many years. My original configuration was based on the link to the PopTray forum you provide in your post. My settings for K9 and the accounts in PopTray U are using port 9999 and the server number as in the instructions and they have access to all ports via the firewall, so I'm completely perplexed as to what might be the problem. Like I said, when I review the K9 logs it appears to be connecting to the POP servers without a problem and logging into the mail accounts and it indicates that emails are being entered into the Spam IP cache and Good IP cache mutuelles TNS, but they never appear in the Recent Emails tab where I usually review them before clicking the Organize button or in the storage areas. The storage area lists all of the Good and Spam messages from my old configuration so I know that the program is able to see the configuration files on the new machine. Any help or other ideas you might have will be appreciated.
I use a filter like that the spams go into the trash and the good messages go into the inbox. It is also necessary to use a powerful antivirus.