Problem with K9 and Poptray

General discussion about PopTray. You love it? You hate it? Talk about it here.

Moderators: KY Dave, jojobear99, Rdsok

Post Reply
Spike143
Still here
Posts: 19
Joined: Sun Sep 08, 2002 5:22 am
Location: Rochester, NY

Problem with K9 and Poptray

Post by Spike143 » Wed Jan 30, 2008 7:07 pm

I am having a hard time getting K9 to see my email. Poptray is working and I am recieving mail but when I look in K9 I see nothing.
I have my accounts setup correctly with 127.0.0.1 and 9999 for the port setting. my logon is "my-server/110/my Email username.
I get all my mail through Poptray so my settings must be correct.

The problem is K9 does not show any of my emails. I went through the config of K9 that you have in your setup to the tee and have redone it at least 6 times now with no success. I know I must be missing something but have no idea what it is. Hope you can help.

My Rules are as follows
Header, Wildcard, *[Spam][5?.?%]*
Header, Wildcard, *[Spam][6?.?%]*

and so-on
I even redone the rules 4 time with no success.
I love poptray but would love it even better to get K9 working with it.
Thanks

User avatar
KY Dave
Not the Developer
Posts: 1599
Joined: Thu Mar 14, 2002 7:29 pm
Location: Burkesville, KY. U.S.A.
Contact:

Post by KY Dave » Wed Jan 30, 2008 7:51 pm

Double Click the K9 icon in the SYSTEM'S TRAY to open K9.

Click on the LOG TAB in K9 and then clear it by clicking the 'X' at the right.

Now check your email account using PopTray.

Does any info appear in the K9 POP3 Proxy Log Window?

If it does have info in the K9 POP3 Proxy Log Window, sometimes EXITING K9 and RESTARTING K9 will cause the info to start appearing in the RECENT EMAIL Window.

If no info appears in the K9 POP3 Proxy Log Window, something is wrong with your setup.

Are you emails being marked as [SPAM]?

In PopTray do you have the box checked in OPTIONS, ADVANCED OPTIONS, for RETRIEVE BODY WHILE CHECKING?
KY Dave

Family Blog
You can STOP SPAM using PopFile and PopTray.

Spike143
Still here
Posts: 19
Joined: Sun Sep 08, 2002 5:22 am
Location: Rochester, NY

Post by Spike143 » Wed Jan 30, 2008 9:19 pm

Well It's working, What I did was uncheck limit download to first 50 lines in the advance tab and I started seeing my email in K9.

Also the info does appear in the log window of K9 after doing a check mail. so thankfuly my settings are correct.

One other question I have is when in K9 and I go to the storage area. I see ? marks in both the good and the spam emails, Is that normal.
I would think that it would be Yes for the Spam and No for the Good.
Is this normal?

Also thank you for all your help.
Spike

User avatar
KY Dave
Not the Developer
Posts: 1599
Joined: Thu Mar 14, 2002 7:29 pm
Location: Burkesville, KY. U.S.A.
Contact:

Post by KY Dave » Thu Jan 31, 2008 12:01 am

Select those with question marks and mark them either SPAM or GOOD for a few days until K9 gets to know what you consider spam.

You can also click SCORE and K9 will score the emails and mark them for you. It will work better after you have marked several emails as spam and good. Depending on the number of spam versus good you get, a couple hunderd should give K9 a good basis to mark them correctly.

I use the WHITELIST in K9.
In K9 on the RECENT EMAIL Tab, if you right click on an email, you can ADD TO WHITELIST the ADDRESS, SUBJECT or several other items.
KY Dave

Family Blog
You can STOP SPAM using PopFile and PopTray.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests