List index out of bounds error

Found a serious/minor bug in PopTray? Tell me about it.

Moderators: KY Dave, jojobear99, Rdsok

Locked
wuttd
Still here
Posts: 8
Joined: Sun Mar 26, 2006 2:12 am

List index out of bounds error

Post by wuttd » Sun Mar 06, 2011 7:35 am

Every time PopTray tries to check the POP server using POP with SSL plugin, an error dialog appears with the message "List index out of bounds (0)." Is there an trace log and/or some other configuration needed to diagnose this bug?

User avatar
Rdsok
PopTray Family
Posts: 1348
Joined: Fri Mar 19, 2004 11:36 pm
Location: Norman, Oklahoma USA
Contact:

Post by Rdsok » Sun Mar 06, 2011 8:15 am

I actually doubt it is a bug but some other issue causing the trouble.


First some general steps you can use for any program error you may see...

1. Clean out all temp files using the Windows Disk Cleanup or similar utility.
2. Restart the computer and test again.

3. If it continues... use Chkdsk to check for and repair disk errors... Instructions can be found here if you don't know how http://support.microsoft.com/kb/315265


Email related suggestion...

1. Remove all email's from your account's Inbox that you are getting the error on. I find a Webmail interface ( if available ) is the easiest way to make certain that no emails exist in the Inbox but you can do it with a standard email client also with the proper settings in it.

wuttd
Still here
Posts: 8
Joined: Sun Mar 26, 2006 2:12 am

List index out of bounds error

Post by wuttd » Sun Mar 06, 2011 8:26 am

Upon further investigation, it appears as if my account setup information had somehow disappeared. I recreated the account and the problem went away. I think the failure condition when checking for mail with non-existent accounts should probably be handled a little more gracefully than the current array index error message. Credit given for at least not crashing the app? Or do you get that for free? :)

User avatar
Rdsok
PopTray Family
Posts: 1348
Joined: Fri Mar 19, 2004 11:36 pm
Location: Norman, Oklahoma USA
Contact:

Post by Rdsok » Sun Mar 06, 2011 6:21 pm

I'm glad you got your issue resolved...

wuttd
Still here
Posts: 8
Joined: Sun Mar 26, 2006 2:12 am

Post by wuttd » Sun Mar 06, 2011 7:44 pm

Thsnks!

Locked

Who is online

Users browsing this forum: Bing [Bot] and 4 guests