IMAPv2 (Delphi) release 0.43 alpha

Writing and using PopTray plug-ins

Moderators: KY Dave, jojobear99, Rdsok

Locked
mjeveritt
Groupie
Posts: 71
Joined: Sun May 04, 2003 2:41 am
Location: Devon, England, UK.

IMAPv2 (Delphi) release 0.43 alpha

Post by mjeveritt » Thu Nov 03, 2005 2:26 am

Just to let ppl know I've released yet another version of the IMAP v2 plugin for you to play with.

You can find it at http://sourceforge.net/project/showfile ... _id=115798

Let me know how you get on.

I shall shortly be embarking on re-writing the plugin to use the open source Synapse libraries. Hopefully this should eradicate a lot of the errors which are hard to find and patch over!
Last edited by mjeveritt on Fri Nov 04, 2005 1:42 am, edited 1 time in total.

Edward Mendelson
Groupie
Posts: 72
Joined: Thu Jun 20, 2002 5:27 am

Post by Edward Mendelson » Thu Nov 03, 2005 3:56 pm

This is a major improvement over the earlier versions in that it doesn't cause a total lockup when trying to preview a message. Unfortunately, it doesn't actually preview the message on my setup (Windows XP); instead the Preview window is blank and won't close when I click the "X" at the upper right, but it does close when I minimize PopTray itself. This is real progress - no need for Ctrl-Alt-Del when I try to preview an IMAP message, which was driving me slightly crazy.

EDIT - Sorry, I was mistaken. In fact the unclosable (and blank) Preview window does stay open - it comes back when I open the PopTray window. So I do need to Ctrl-Alt-Del to close that window. Also, I get "incompatible plugin" messages when I start PopTray with the new version enabled.

mjeveritt
Groupie
Posts: 71
Joined: Sun May 04, 2003 2:41 am
Location: Devon, England, UK.

Post by mjeveritt » Fri Nov 04, 2005 1:44 am

Hmm, seems like there are still issues with the plugin detecting the end of an email message .. hence why it appears to 'hang' .. it is, in fact, in an infinite loop .. stupid software! I'll have a look, but can't guarantee anything ... !

User avatar
ilNebbioso
PopTray Family
Posts: 773
Joined: Fri Feb 01, 2002 10:30 am
Location: Milan, Italy
Contact:

Post by ilNebbioso » Mon Dec 12, 2005 6:52 pm

Using 0.43alpha PT 3.2beta2 gives me error switching to the Options->Plug-In with error "incompatible plugin". What's wrong?

Obviously I closed PT before copying the new plugin.

mjeveritt
Groupie
Posts: 71
Joined: Sun May 04, 2003 2:41 am
Location: Devon, England, UK.

Post by mjeveritt » Mon Dec 12, 2005 10:43 pm

Looks like I need to update the version of Poptray I use for testing. God knows which one it is .. I can never keep up with Renier.

Progress slow on the Synapse work .. for some reason Delphi doesn't seem interested in debugging it!! Maybe I need to add sources or something.

User avatar
AveNgeR
Evolving
Posts: 21
Joined: Sat Jul 26, 2003 5:54 am
Location: Aachen, Germany
Contact:

Post by AveNgeR » Tue Apr 11, 2006 1:12 pm

ilNebbioso wrote:Using 0.43alpha PT 3.2beta2 gives me error switching to the Options->Plug-In with error "incompatible plugin". What's wrong?
Same Problem here with PT 3.2b4...

I am really interested in new IMAP Plugins an will be happy to help testing.

Locked

Who is online

Users browsing this forum: No registered users and 1 guest