A kind of Access violation with POP3 HTML Reader plugin

Writing and using PopTray plug-ins

Moderators: KY Dave, jojobear99, Rdsok

Locked
User avatar
homaquebec
PopTray Family
Posts: 913
Joined: Tue May 27, 2003 6:47 pm
Location: Québec (Canada)

A kind of Access violation with POP3 HTML Reader plugin

Post by homaquebec » Tue Jan 24, 2006 3:05 pm

This morning, at the first checking of the mail by PopTray, I got an error message indicating problems for the POP3 HTML Reader plugin to read the mail. It looked that the precedent access violation message coming for PopTray. With K9, I saw that it was exactly the same kind of message that gave the problem. I desabled the plugin, shut down Poptray, reopened it and checked the mail. Everything worked fine.

To follow.

User avatar
rsleegers
Enthusiast
Posts: 49
Joined: Fri Apr 02, 2004 4:34 pm
Location: Ontario, Canada
Contact:

hmm

Post by rsleegers » Tue Jan 24, 2006 8:32 pm

So you are saying that there was some sort of access violation during checking, but when you closed PopTray and re-opened it work fine? Or did you leave the plugin disabled.

If you left it disabled, and you re-enable the plugin after restarting PopTray, do you still see the a/v? and if so, what were the error numbers?
Richard
PopTray 3.2 (beta 5) RC1
http://ca.geocities.com/rsleegers/PopTray/

User avatar
homaquebec
PopTray Family
Posts: 913
Joined: Tue May 27, 2003 6:47 pm
Location: Québec (Canada)

Additional information

Post by homaquebec » Tue Jan 24, 2006 8:35 pm

An information I must add: this problem happened after having, yesterday, installed the version 3.2 beta 4 of PopTray.

User avatar
homaquebec
PopTray Family
Posts: 913
Joined: Tue May 27, 2003 6:47 pm
Location: Québec (Canada)

Re: hmm

Post by homaquebec » Tue Jan 24, 2006 8:37 pm

rsleegers wrote: [...]If you left it disabled, and you re-enable the plugin after restarting PopTray, do you still see the a/v? and if so, what were the error numbers?
I will re-enable the plug-in and make a test. Information about the results will follow.

There was no error number; it was a written message.

User avatar
homaquebec
PopTray Family
Posts: 913
Joined: Tue May 27, 2003 6:47 pm
Location: Québec (Canada)

The facts

Post by homaquebec » Tue Jan 24, 2006 8:58 pm

I re-enabled the plug-in, shut down Poptray and reopened it.

I sent me a message with this subject using a hotmail account (the same subject that caused the Access violation error in PopTray 3.2 version 2): Relevez le =?ISO-8859-1?Q?d=E9fi?= avant le 14 novembre
=?ISO-8859-1?Q?=E0_16_h_!?=

Here is the message that I got when PopTray checked the mail:

Image

User avatar
rsleegers
Enthusiast
Posts: 49
Joined: Fri Apr 02, 2004 4:34 pm
Location: Ontario, Canada
Contact:

Post by rsleegers » Tue Jan 24, 2006 11:03 pm

That certainly appears to point at the plugin. You say you see it when you "Check" the mail? and not when you "Open" the mail, correct? The way the plugins work is to allow a bit of extra work without redoing everything. That means for some parts, the main PopTray is actually do the work, with the plugin only doing additional work.

I don't mean to "pass the buck", but I have seen subject decoding problems in other posts when there is encoding within the subject. A lot of times that is related to the Indy code being used, which neither Renier nor I work on, just re-use.

That said, I will try to see if I can make the same error happen using that subject or variations to see where the error is happening.
Richard
PopTray 3.2 (beta 5) RC1
http://ca.geocities.com/rsleegers/PopTray/

User avatar
Renier
Site Admin
Posts: 1956
Joined: Mon Oct 15, 2001 12:54 pm
Location: Cape Town, South-Africa
Contact:

Post by Renier » Wed Jan 25, 2006 9:38 am

I've re-compiled PopTray with Delphi and the default Indy 9 that comes with that (not sure which version that is), and the subject decoding problem went away. I think it might be a bug in some of the versions of Indy 9. Maybe you can try to recompile your plugin with a different version too.

User avatar
rsleegers
Enthusiast
Posts: 49
Joined: Fri Apr 02, 2004 4:34 pm
Location: Ontario, Canada
Contact:

Post by rsleegers » Wed Jan 25, 2006 5:41 pm

I probably used v10 of Indy, so I'll try v9 when I take a look at the plugin again.
Richard
PopTray 3.2 (beta 5) RC1
http://ca.geocities.com/rsleegers/PopTray/

Locked

Who is online

Users browsing this forum: No registered users and 2 guests