Page 1 of 1

filter question

Posted: Wed Jan 05, 2005 7:07 am
by mcdj
First off, thanks to the creators of Pop Tray. I adore it!

My problem is, it seems the vast majority of spam I get is mass addressed to a bot-created list of names similar to mine at my ISP, nyc.rr.com. I have a very small handful of friends, etc. who also have nyc.rr.com email accounts.

So, I'll get a spam addressed to joeblow@nyc.rr.com, joeblue@nyc.rr.com, joblew@nyc.rr.com, etc. Rarely are the emails I get from friends, associates etc. addressed to more than one person at nyc.rr.com...me...with the exception of the occasional E-vite and forwarded jokes.

So I'm wondering, is there a way to create a filter that detects multiple recipients at nyc.rr.com (always spam), but lets the ones addressed to me and only me (or other folks not at nyc.rr.com) get through?

TIA,

mcdj

Posted: Wed Jan 05, 2005 12:36 pm
by quosego
Take a look at this topic:
viewtopic.php?t=2071&highlight=

The answer to your question is given by sandy&cloud

thanks...but

Posted: Wed Jan 05, 2005 5:55 pm
by mcdj
Maybe I'm doing something wrong, but now any email to my address is marked as spam, even if it's only to my address and no one else's.

ahh..now I get it!

Posted: Wed Jan 05, 2005 7:16 pm
by mcdj
In the filter example posted by sandy&cloud, [^e]@myprovider\.com, the [^e] should read [^me], which didn't dawn on me till now. I changed it to my username and now it works perfectly. Thanks.

Re: ahh..now I get it!

Posted: Fri Jan 14, 2005 4:28 pm
by lemming
Unfortunately, the regex posted by sandy&cloud is inaccurate, and so is the solution you suggested.

[^me] does not mean "anything except me", it means "any single character, except m and e". So if you create something like [^randy], it will match a single character that is not r, a, n, d, or y.

For a better way, refer to my solution at the same thread

viewtopic.php?p=11371#11371

-Lemming.
mcdj wrote:In the filter example posted by sandy&cloud, [^e]@myprovider\.com, the [^e] should read [^me], which didn't dawn on me till now. I changed it to my username and now it works perfectly. Thanks.