Incompatibility with Windows Vista beta 2

General discussion about PopTray. You love it? You hate it? Talk about it here.

Moderators: KY Dave, jojobear99, Rdsok

Post Reply
Hugh
Still here
Posts: 12
Joined: Fri Jun 23, 2006 5:40 pm

Incompatibility with Windows Vista beta 2

Post by Hugh » Fri Jun 23, 2006 7:11 pm

Several images don't look good. Even when I switch to Windows Classic style it doesn't look good. I.e. the email bitmap in the traybar is now completely white. I know I can manipulate the images (however, when I open that file the images look good), but I'd prefer a compatible skin.bmp in the next beta. Thanks.

User avatar
Rdsok
PopTray Family
Posts: 1418
Joined: Fri Mar 19, 2004 11:36 pm
Location: Norman, Oklahoma USA
Contact:

Post by Rdsok » Fri Jun 23, 2006 7:58 pm

If you plan on running beta OS software such as Vista... you can just expect problems to show up. I also wouldn't call this an "Incompatibility", it may not be desireable but if Poptray is running ok then there is nothing incompatible about it. An incompatible item would be one that caused the program or another program to have errors and actually not work.

I also can't say if Renier ( the author of Poptray ) has plans to upgrade to Vista or not... you would probably be better off trying to create your own skin.bmp at this point to see if you can get one that looks proper to you or not... otherwise you are in for a long wait I would suspect.

User avatar
KY Dave
Not the Developer
Posts: 1599
Joined: Thu Mar 14, 2002 7:29 pm
Location: Burkesville, KY. U.S.A.
Contact:

Post by KY Dave » Fri Jun 23, 2006 8:08 pm

Another possibility would be...

is your current graphics card actually compatable with Vista?

From the items I have read, there are actually very few graphics cards that will display the AERO enviroment correctly.
KY Dave

Family Blog
You can STOP SPAM using PopFile and PopTray.

Hugh
Still here
Posts: 12
Joined: Fri Jun 23, 2006 5:40 pm

Post by Hugh » Fri Jun 23, 2006 8:43 pm

KY Dave wrote:Another possibility would be...

is your current graphics card actually compatable with Vista?

From the items I have read, there are actually very few graphics cards that will display the AERO enviroment correctly.
Yes, my "Mobile Intel(R) 915GM/GMS/910GML Express Chipset Family (Microsoft Corporation)" is working fine. Windows Vista in general is working great. No conflicts in the hardware.

Hugh
Still here
Posts: 12
Joined: Fri Jun 23, 2006 5:40 pm

Post by Hugh » Fri Jun 23, 2006 8:52 pm

Rdsok wrote:If you plan on running beta OS software such as Vista... you can just expect problems to show up.
I haven't encountered similar problems in other applications so far. In PopTray, the button images such as the images next to Run Email Client, Check All, To Tray, Help, Refresh, Test and the envelope in the system tray and next to the account buttons are completely white/gone. All other images in PopTray look good.

User avatar
Rdsok
PopTray Family
Posts: 1418
Joined: Fri Mar 19, 2004 11:36 pm
Location: Norman, Oklahoma USA
Contact:

Post by Rdsok » Sat Jun 24, 2006 1:17 am

Increase or decrease the number of colors shown for your video display ( color depth ) and see what happens...

PS just because of the few limited number of programs you have run on it doesn't seem to have issues doesn't mean that others have no issues... for instance... most antivirus and firewall software have had to be updated for it and those are just two types... The fact still remains that Vista is beta software that is still not ready for the official release and to expect all other programs to work without some issues is simply naive.

User avatar
Rdsok
PopTray Family
Posts: 1418
Joined: Fri Mar 19, 2004 11:36 pm
Location: Norman, Oklahoma USA
Contact:

Post by Rdsok » Sat Jun 24, 2006 1:24 am

Oh.. here ya go.... perhaps you can send Renier the computer that is capable of running Vista and even possibly a copy of it already installed so he will have the equipment needed to do the testing with to be able to meet your request... :lol:

Hugh
Still here
Posts: 12
Joined: Fri Jun 23, 2006 5:40 pm

Post by Hugh » Sat Jun 24, 2006 9:15 am

Even with 32 bit colors it doesn't help. Meanwhile, I found out that the envelope image in the tray bar IS visible for a while (so we can now eliminate the video problem), but during the mail check it turns white with only the shape of it visible. When I open PopTray before the mail check is done, the image stays good. I haven't been able to reproduce this behaviour with the other images yet.

Hugh
Still here
Posts: 12
Joined: Fri Jun 23, 2006 5:40 pm

Post by Hugh » Sat Jun 24, 2006 9:19 am

Rdsok wrote:perhaps you can send Renier the computer
Well, it's actually on a laptop, so the weight wouldn't be a big problem :) . I'll see if I can upload a screenshot today.

User avatar
Rdsok
PopTray Family
Posts: 1418
Joined: Fri Mar 19, 2004 11:36 pm
Location: Norman, Oklahoma USA
Contact:

Post by Rdsok » Sat Jun 24, 2006 5:12 pm

Hugh wrote:Well, it's actually on a laptop, so the weight wouldn't be a big problem :) . I'll see if I can upload a screenshot today.
I don't think a screenshot would be needed, your description was good enough... but to address this, if it isn't just a problem related directly with your video drivers like the blacked out icons of Win9x were, the programmer would have to be able to recreate the issue on a test system.

User avatar
Renier
Site Admin
Posts: 1957
Joined: Mon Oct 15, 2001 12:54 pm
Location: Cape Town, South-Africa
Contact:

Post by Renier » Sat Jun 24, 2006 6:17 pm

Hmm, interesting.

I wonder if this has to do with a general Delphi problem, or is it something very specific that I do with those icons that Vista doesn't like.

Have you tried renaming skin.bmp to PropTray.skin? Maybe the way it then loads all the bitmaps in the same way, either all icons will disappear, or they will all work. Otherwise I don't understand why some will work and others don't.

You can also try switching off the animated star for the TrayIcon to see if the re-mixing of the colors that I'm doing there is causing this.

Unfortunately I have a 3GB per month download limit on my internet connection, so downloading Vista beta is not possible for me. (Can you even dual-boot reliably?)

I will probably switch to Vista once it gets released (and the worst teething problems are sorted), but until then, I'm not sure how I can solve this.

Pity if the OS isn't 100% backwards compatible. Maybe they'll fix it before the final release.

Hugh
Still here
Posts: 12
Joined: Fri Jun 23, 2006 5:40 pm

Post by Hugh » Mon Jun 26, 2006 12:58 pm

Sorry for the delay. Renaming skin.bmp only made things worse. No images at all. I've tried the Windows Classic skin, but that didn't help. I could send you an installation DVD. You will only have to get your product key at the Microsoft site. I agree that it still isn't sure if this problem is caused by Vista or that PopTray needs an update.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests