Help requested on colliding rules

Found a serious/minor bug in PopTray? Tell me about it.

Moderators: KY Dave, jojobear99, Rdsok

Locked
User avatar
metalmakker
Evolving
Posts: 22
Joined: Sun Oct 19, 2003 12:00 am
Location: Netherlands

Help requested on colliding rules

Post by metalmakker » Mon Oct 20, 2003 3:20 pm

For example: I have a rule that says; delete anything with the word SPAM in the subject line. I also have a rule that says; anything that is sent by an address with @ebay.com in the senders address should be protected from automatic deletion.

Now email from ebay.com is marked protected, but when the word spam is in the subject line it gets deleted anyway. (My provider has this filtering program that adds the line Possible Spam into the subject line. Handy when you make a rule that anything with that line should be deleted. Not so handy when their filtering program is not 100% accurate and marks almost every ebay email.)

In the rules log file it says the mail arrived, was protected, but still... the mail has been deleted. Can I fix this somehow? Can rules be prioritized?
If it's too fast, you're too old...

User avatar
Renier
Site Admin
Posts: 1957
Joined: Mon Oct 15, 2001 12:54 pm
Location: Cape Town, South-Africa
Contact:

Post by Renier » Mon Oct 20, 2003 3:37 pm

I have just tested it on my side and the protect rule did protect it against deletion.

User avatar
metalmakker
Evolving
Posts: 22
Joined: Sun Oct 19, 2003 12:00 am
Location: Netherlands

Post by metalmakker » Mon Oct 20, 2003 11:38 pm

I don't get it... now it works! I tried it out with my own email address and now I do get the message. It does log the action, but the email is still there. I did lose several emails yesterday, so I don't understand what went wrong.
Well, if it all stays this way that's cool.
Poptray continues to be the best email management tool I found on the web, THANKS!!
If it's too fast, you're too old...

Locked

Who is online

Users browsing this forum: No registered users and 9 guests