Ignore - Socket Error #10054

Found a serious/minor bug in PopTray? Tell me about it.

Moderators: KY Dave, jojobear99, Rdsok

Posts: 23
Joined: Mon Mar 14, 2005 11:53 am

Ignore - Socket Error #10054

Post by Dilas » Mon Mar 14, 2005 8:14 pm

I use PopTray 3.1 Beta 8 on 2 PCs with WinXP Prof. SP2

On the first PC everything works fine (by the way: Poptray is an excellent piece of software :D - if it works :? )

On the second PC (with the same configuration and the same e mail accounts) I get from time to time the "Socket error 10054 - connection reset by peer"

I have read everything about this error in this and other forums and tried nearly everything to solve the problem. Without success.

The only thing that helps is to ignore the problem and the error message.

My problem is, that the advanced option "Ignore connection errors" does not work/help.

The popUp window with the error message "Socket ..." appears everytime. :o

Whats wrong/can I do?

Posts: 23
Joined: Mon Mar 14, 2005 11:53 am

Post by Dilas » Mon Mar 14, 2005 8:47 pm

I have just noticed the following behaviour of Poptray:

1. e mail checking
2. Socket error 10054 (not displayed - ignored) :)
3. e mail checking
4. now the above error message (Socket error 10054) pops up and the poptray notice window shows the message: already connected (on the left corner) :o
5. e mail checking
6. everything works fine :D

and back to 1.

Posts: 23
Joined: Mon Mar 14, 2005 11:53 am

Post by Dilas » Mon Mar 14, 2005 11:16 pm

Some more informations that might help to solve the problem:

No DialUp connection is used

the connection is handled by a router which ist online for 23:59 hours a day without disconnection

the error appears with different e mail accounts and different providers

the error does not appear on another PC

.....so my opion has been, that the TCP/IP / MTU / Stacks etc settings are wrong...but every change I ve tried did not solve the problem.

I use adware und Bitdefender AntiVir. No Proxy Server. DSL LAN Network...

the error appears only with poptray....

Posts: 23
Joined: Mon Mar 14, 2005 11:53 am

Post by Dilas » Tue Mar 15, 2005 9:42 pm

now I know the reason for the "Socket Error 10054" :!:

=> its cause by BitDefender 8.0 Pro an AV Software. :x

If I disable "scan incoming mail for viruses" everything works fine ! :lol:

I ve mailed this problem to the Bitdefender Support Team.
Lets see, what will happen ! :wink:

I hope this can help other users with the same problem.
Disable your AV software and see what happens :idea:

First Timer
Posts: 3
Joined: Fri May 06, 2005 9:59 am
Location: Germany

Post by teakay » Fri May 06, 2005 10:12 am

Hello Dilas.

I have the same Problem, but i´m sure that is not the reason by bitdefender. Becouce i´m using Poptray 3.03 and Bitdefender 8 Pro on my Desktop PC and ther i have no problems. And i´m using Poptray 3.1 and Bitdefender 8 Pro on my Notebook and on the Notebook i get the same error Message.
I think there is a Problem with Poptray 3.1.
Otherwise Poptray is genious Prog.

Apology for my English, I not very often uses it. :wink:

Posts: 23
Joined: Mon Mar 14, 2005 11:53 am

Post by Dilas » Sat May 07, 2005 3:15 pm

I did not test it with PopTray 3.03 but with 3.1 ´an BitDefender 80 Pro it does definitly NOT work. :(

Bitdefender Support team told me, that there is no bug in Bitdefender. :(

I hope the PopTray team will fix this problem... :roll:

User avatar
PopTray Family
Posts: 1463
Joined: Fri Mar 19, 2004 11:36 pm
Location: Norman, Oklahoma USA

Post by Rdsok » Sun May 08, 2005 5:38 am

I've seen no trouble using AVG Free's email scanner... email proxy scanners like these both use are always problematic (not matter what BitDefender says).

Other possible things to consider...

malware of any type... virus or spyware etc. See this for help in this area http://www.computerbob.com/guests/how_t ... mputer.php . Note that in that article, I am using AVG instead of BitDefender... just substitute your AV where the other is mentioned.

Another possible cause going in an area you where checking already... (I moderate on the AVG forum.. I'll just post my normal post for this without editing it..)

Many AVG update problems have been attributed to a corrupted Winsock/TCP-IP stack. While you may have what appears to be normal access to the internet and email, other functions may not be working properly. To fix these types of problems, download one of the utils mentioned below selecting the one for your Windows version.

For WinXP systems get WinsockXPFix from http://www.snapfiles.com/get/winsockxpfix.html

For all other versions get WinSockFix from http://www.majorgeeks.com/download4372.html

First Timer
Posts: 1
Joined: Sat May 21, 2005 1:03 pm

Post by Brainy » Sat May 21, 2005 1:09 pm


I had the socket error even after reinstalling PopTray several times. Now I found out that choosing another language than English (in my case it was German) makes the difference. With English chosen PopTray works fine and no error message is popping up.

Hope it helps!


Still here
Posts: 9
Joined: Sat May 21, 2005 9:54 am
Location: Germany

Socket Error 10054 Connection Reset by Peer

Post by Helmut » Thu Jul 14, 2005 10:35 am

This error message I had received before with the last stable version, but I was able to disable checking and reenabling it. Then the error would disappear. With the 3.2 Beta 1, this was not possible. I had to exit the program, then restart it. That cured the deadlock.

I use a DSL connection, no dial up.

Proposal: why not put the stop button next to the check button in the interactive (full) mode?

I noticed, that on the first attempt after starting the network, there is always a connection problem. The second run usually works fine then.

By the way, the animation character shows, but is static, not animated.




First Timer
Posts: 1
Joined: Thu Aug 25, 2005 12:57 pm

Post by cay » Thu Aug 25, 2005 1:53 pm

I face the same error on my desktop and on my notebook also, using Bitdefender 8.0. Tried the stable version 3.1 as well as the 3.2 (beta 1). Also after restart the error occurs again and again after a few minutes so that PopTray seems to be unusable for me. :(
It's a pity because I like the features of poptray more than MagicMail that causes no errors.

Hint: MagicMail is realised as a mail program by Bitdefender and Windows and BitDefender checks mails that are opened by MagicMail. PopTray seems to be a neutral application for both. Can it be that another declaration would fix this problem also. I would like to hear an answer.

Thanks and regards

First Timer
Posts: 1
Joined: Thu Oct 13, 2005 2:45 pm
Location: Amersfoort, the Netherlands

Post by puchelaar » Thu Oct 13, 2005 2:50 pm

Had the same problem after upgrading from 3.03 to 3.2 beta1 (didn't uninstall first btw). Tried Brainy's suggestion to change the language (had English, tried Afrikaans), but that didn't help, so I changed back to English. An lo and behold; problem solved!
Don't know what the problem was, but maybe others can tinker around some with the language as well and maybe that'll help.

Otherwise Poptray has been in my tray for a couple of years now and wouldn't want to miss it \o/

First Timer
Posts: 4
Joined: Thu Aug 18, 2005 7:12 pm

My solution for Socket error 10054

Post by Muuhle » Fri Oct 21, 2005 8:21 am

I had that problem while my inbox was too full. I solved it, deleting a few big mails from the postbox. Good luck!



Who is online

Users browsing this forum: No registered users and 7 guests