Access violation

Found a serious/minor bug in PopTray? Tell me about it.

Moderators: KY Dave, jojobear99, Rdsok

First Timer
Posts: 2
Joined: Sun Oct 23, 2005 10:06 am

Post by Cybernoid » Fri Dec 23, 2005 11:11 pm

It's not the size of the message, I got the same error again, but now the message that caused it was an out-of-office-reply, only about 4K.

I have the message in my Outlook inbox now, if anyone needs it. :)

First Timer
Posts: 1
Joined: Mon Jan 02, 2006 10:36 pm

Maybe a reason for the access violation

Post by liqui » Mon Jan 02, 2006 10:52 pm

I have the same problem with access violations at version 3.2 beta2. Before I used version 3.1 without this problem.

I also found out that it was one email stored for weeks on the mailserver, so first time I used the new beta it crashed.

I tried a lot and for me it seems to be the difference between some mailclients encoding the subject line.

The line that makes problems is:

Subject: =?iso-8859-1?Q?Eingangsbest=E4tigung=3B_Aktenzeichen_512-2_EB-?=

([TAB] is deleted by this forum...)

So I sent many Testmails with this subject to myself encoding ISO-8859-1 but in no case it brought an error.

I was using some webmailers and thunderbird.

And the only difference inside the source code of the mails compared to the original that created the error was:

The second line of the subject starts with an tabulator-space.

All the subjects lines of the mails I sent to myself looked different, e.g. like that:

Subject: =?ISO-8859-1?Q?Eingangsbest=E4tigung=3B_Aktenzeichen_512-2_?=

([SPACE] is also deleted...)

But the only one that caused the error had an tabulator on the beginning of the second line:

Subject: =?iso-8859-1?Q?Eingangsbest=E4tigung=3B_Aktenzeichen_512-2_EB-?=

But I could not recognize it because I have no mailclient, that encodes the subject line like that.

The original mail that causes the error was written with:
X-Mailer: Internet Mail Service (5.5.2653.19)

I could send the hole source to you...
I hope it helps to recognize the bug. The version 3.1 read this mail without the access violation...

Best Regards

User avatar
PopTray Family
Posts: 916
Joined: Tue May 27, 2003 6:47 pm
Location: Québec (Canada)

The guildty code

Post by homaquebec » Tue Jan 03, 2006 12:00 am


I identified the guilty code as I explained in this post. Your message in an other proof.

User avatar
Site Admin
Posts: 1957
Joined: Mon Oct 15, 2001 12:54 pm
Location: Cape Town, South-Africa

Post by Renier » Wed Jan 04, 2006 8:47 am

The next time I work on PopTray, I will look at this bug first. I now have a lot of examples of emails causing this.

User avatar
Site Admin
Posts: 1957
Joined: Mon Oct 15, 2001 12:54 pm
Location: Cape Town, South-Africa

Post by Renier » Sun Jan 22, 2006 10:24 pm

I've been able to re-create this error using the subjects lines mentioned here, and from the email samples people have sent me.

Since the previous release of PopTray, I've since bought myself a new PC. I Installed Delphi with Indy 9 on the new PC, and compiled PopTray. Now this bug doesn't happen anymore.

I'm probably using a different version of Indy (I haven't checked), but at least for now the error is gone (without me changing any code).

So fixed in PopTray 3.2 (beta 3), I guess.


Who is online

Users browsing this forum: No registered users and 6 guests