IMAP plugin hangs when previewing an unread message

Found a serious/minor bug in PopTray? Tell me about it.

Moderators: KY Dave, jojobear99, Rdsok

Locked
bburtin
First Timer
Posts: 3
Joined: Wed Oct 26, 2005 10:43 pm

IMAP plugin hangs when previewing an unread message

Post by bburtin » Wed Oct 26, 2005 10:52 pm

Thanks for developing PopTray! Overall I'm a very happy user, but I did notice one glitch.

I'm running PopTray against the Zimbra mail server using the IMAP protocol. PopTray works great for detecting new messages, but hangs when previewing.

I traced the protocol and noticed that the hang only occurs when I preview an unseen message. When a message is unseen, the server returns "FLAGS (\Seen)" at the end of the response. If I kill PopTray and preview the same message a second time, the preview succeeds.

Seems like the response is valid. Even if it wasn't, PopTray should respond with an error rather than hanging.

Boris

mjeveritt
Groupie
Posts: 71
Joined: Sun May 04, 2003 2:41 am
Location: Devon, England, UK.

Post by mjeveritt » Thu Oct 27, 2005 9:18 pm

Which version of the IMAP plugin ... :P

Welcome to the wonderful world of IMAP :D

bburtin
First Timer
Posts: 3
Joined: Wed Oct 26, 2005 10:43 pm

Post by bburtin » Thu Oct 27, 2005 9:26 pm

For the life of me I can't figure out how to get the plugin to give me a version number. I looked in the PopTray UI and tried looking at the properties of the DLL. I'm pretty sure it's the one from the "Examples" bundle. I just realized there's another IMAP plugin on the download page at

http://www.poptray.org/plugins.php

I'll see if I have any better luck with that one.

Boris

Edward Mendelson
Groupie
Posts: 72
Joined: Thu Jun 20, 2002 5:27 am

Post by Edward Mendelson » Mon Oct 31, 2005 9:35 pm

This has been a problem (at least on my machines) ever since the first IMAP plugin appeared, and it seems to occur with ALL IMAP plugins. I've never been able to preview a new IMAP message without making PopTray lock up.

mjeveritt
Groupie
Posts: 71
Joined: Sun May 04, 2003 2:41 am
Location: Devon, England, UK.

Post by mjeveritt » Tue Nov 01, 2005 1:41 am

If the developers never receive an accurate bug report, how are we supposed to find out what's going wrong? I know telepathy is a rare skill, but few programmers possess it!

The Delphi debug build creates an Errorlog file which if sent back to me I can look at what stage the plugin is crashing, and some of the data it is attempting to process.

As I have said before, those programmers who've worked with the IMAP specification have found it difficult to implement and work with, and the delphi libraries which are supposed to make interfacing easier appear to have funtionality missing or just simply bugs in the existing code which we have to work around (or I certainly have).

So I call once again for some more detailed information if you want me to investigate the problems users are experiencing.

bburtin
First Timer
Posts: 3
Joined: Wed Oct 26, 2005 10:43 pm

Post by bburtin » Tue Nov 01, 2005 2:37 am

I tried switching to the IMAP debug plugin. Now I get "Access violation at address 00E10153 in module 'ProtocolIMAP4.dll'. Write of address 00000008." when I connect to the IMAP server. Content of IMAPerrors.log is below. Is there a way to add attachments to posts? I don't see a button that lets me do this.

--------------

ListMailBoxes Result:
LIST (\HasNoChildren) "/" "Archive"
LIST (\HasNoChildren) "/" "Checkins"
LIST (\HasNoChildren) "/" "Drafts"
LIST (\HasNoChildren) "/" "INBOX"
LIST (\HasNoChildren \Noinferiors) "/" "Junk"
LIST (\HasNoChildren) "/" "Notifications"
LIST (\HasNoChildren) "/" "P4 inbox"
LIST (\HasNoChildren) "/" "Sent"
LIST (\HasNoChildren) "/" "Trash"
LIST completed
Mailbox0: Archive
Mailbox1: Checkins
Mailbox2: Drafts
Mailbox3: INBOX
Mailbox4: Junk
Mailbox5: Notifications
Mailbox6: P4 inbox
Mailbox7: Sent
Mailbox8: Trash

Locked

Who is online

Users browsing this forum: No registered users and 3 guests